Chassis blueprints/ irregularities?

Technical and Repair Discussions

Novice Typer
Novice Typer
Posts: 22
Joined: Sun Nov 19, 2017 1:35 pm
PostPosted: Sat Nov 03, 2018 2:15 pm
Hi
I'm wondering if anyone is aware of blueprints for the SR chassis? Mike Davies at SCCA-E has told me that there are no drawings, which seems odd. To what specifications are major repairs done to frames?
The reason I'm looking for information is that I've discovered some oddities with the front end of my chassis / suspension when comparing (with other cars) the orientation of the front suspension to the main front bulkhead of the frame. There is some evidence of previous crash damage to my chassis (#205) but not enough to explain what I'm seeing. The situation is that the top ball joint on my front suspension is about 20 mm 13/16" further forward than other cars (less caster) . I measured this by putting a straight edge across the front frame bulkhead and measuring back to each upper ball joint. In addition it appears that the old pressed upper control arms locate the ball joints about 1/4" further forward (less caster) than the new tubular rocker arms. This was confirmed by measuring several "thought to be good" pressed rockers. Mike Davies said that there should be no difference....?
I had been having a problem getting enough adjustment to give anything over 3 deg. caster until I discovered that there is a longer version of the lower trailing front suspension link. Although, even even though when this was corrected and I was able to get front caster adjusted to 6+ deg., I still am struggling to tune out poor turn in and heavy understeer. I have tried running 4+ deg neg. to -5 deg neg camber, and 4 to 6 deg. + caster.
I'm not sure if the location of my (virtual ) kingpin location so far forward is a culprit or not, I can see that this would effect the ackermann steering geometry , by moving the hubs forward to the axis of the steering rack.. The location of my front wheels is noticeably further forward in the wheel opening than other cars I see and tires rub on the front wheel arches.
Any thoughts?
Glenn

Forum Hermit
Forum Hermit
Posts: 101
Joined: Sun Jan 01, 2012 10:44 pm
PostPosted: Sat Nov 03, 2018 10:45 pm
some drawings here: http://www.mummbrothers.com/SRF_Stuff/SRFMainPage.htm
User avatar
Needs a Life!!!
Needs a Life!!!
Posts: 703
Joined: Wed Nov 30, 2011 12:21 am

Chassis:
595
PostPosted: Sun Nov 04, 2018 12:39 pm
The shop I work out of has a number of jigs to help align the major suspension points in the event major repairs are needed. If you are in reasonable proximity to a CSR or reputable race shop that works on SRF's you may want to consider having them take a look at your chassis, especially the control arm mounting point

I haven't seen a measurable different between the tubular control arms and a straight old-style; From your description it sounds like the tubular control arms are even fruther forward as measured at the upper ball (+1"?) That seems to point to the control arm mounts as the culprit.

Rather than measure to the upper ball joint, I'd suggest measuring the control arm mount locations. Chances are these were damaged and replaced at some point, and likely not properly aligned (check both horizontally and vertically and both the front and rear sides of the mounting bracket.) 1" is a lot and it should be obvious when viewing the mounts. I'd also check that the mount holes haven't been "hogged" out. I've seen some pretty flaky repairs to mitigate alignment or wear issues (e.g. welding in washers) to avpid having to cut out and weld in new mounts (which you can purchase from Enterprises).

On the handling side, if you're following the Hoosier setup recommendations published a while back, you shouldn't have massive understeer. I assume you've worked the usual bar/shock changes to coiunter understter. The most common problem I run into when cars don't behave properly are bad shocks. What condition are they in? For example, if you step down on the rear of the chassis, does it compress and rebound easily? Often the issue is one shock that only becomes obvious when you remove it from the car and compare against the other shocks (e.g. compresses too easily, extends too easily, girgling, loss of gas pressure, etc.) At some point, they may all be weak and it's time for a rebuild (e.g. if you can compress reasonable easily.)
Bob Breton - SRF 51 - San Francisco Region
User avatar
Needs a Life!!!
Needs a Life!!!
Posts: 735
Joined: Wed Nov 30, 2011 1:03 am

Chassis:
828
Facebook Page:
http://www.facebook.com/#!/denny.stripling
PostPosted: Sun Nov 11, 2018 2:26 pm
Glenn, check to make sure the mount tabs for the rocker arm are a) straight and b) don't have wallowed out holes. What you're describing sounds to me like the rocker might be bolted in at an angle. Another way to check - check the distance from the front upper frame member (just ahead of master cylinders) to the bolt that holds the rocker to the shock. If that distance is out of whack as well, your rocker is probably bolted in at an angle (long bolt not parallel to chassis). If that's the case, check the mounting tabs.
____________
Bay 12, please.

Still Learning to Type
Still Learning to Type
Posts: 25
Joined: Tue Sep 02, 2014 8:56 am
PostPosted: Mon Nov 12, 2018 12:10 pm
This was provided by SCCA Enterprises some years ago.
IMG_3095 (4) (3).jpg
IMG_3095 (4) (3).jpg (47.75 KiB) Viewed 721 times
Attachments
IMG_3107 (5).JPG
IMG_3107 (5).JPG (125.02 KiB) Viewed 721 times

Novice Typer
Novice Typer
Posts: 22
Joined: Sun Nov 19, 2017 1:35 pm
PostPosted: Wed Nov 14, 2018 1:37 am
Thanks for the feedback.
Here are some photos to show what i'm talking about. The measurements vertically for the front rocker location check out as per the SCCA bulletin. What seems off is the fore /aft location of the rocker. The second photo shows just how far forward the outer ball joint is in relation to the straight edge against the front frame tubes.
frame 1.jpg
just under 2 inches from front of bulkhead to front of rocker
frame 1.jpg (69.42 KiB) Viewed 626 times

In comparison to a un-named competitors' car (former national champion fast guy) they had a gap of 3/4" plus here using the tubular rockers. From what I measured in my comparisons the tubular rockers account for 1/4" of this (Positive Caster)
Could it be that later frames are built in with more caster by locating the upper control arms further back? I found that the newest lower trailing links are made longer to facilitate this
Attachments
frame 2.jpg
front edge of ball joint plate parallel to front of frame
frame 2.jpg (65.56 KiB) Viewed 626 times
User avatar
Needs a Life!!!
Needs a Life!!!
Posts: 1184
Joined: Wed Nov 30, 2011 1:38 am
Location: Sunnyvale, CA
Chassis:
068 415
Facebook Page:
http://facebook.com/HSERacing
PostPosted: Wed Nov 21, 2018 10:04 pm
I'm not with a car, but I don't think there's much room to move the mount points back.
Dave Harriman
"It looks crazy, I understand. But, we only live once and I am going to give it a good try." - Alex Zanardi
User avatar
Still Learning to Type
Still Learning to Type
Posts: 26
Joined: Sun Jul 06, 2014 11:14 pm
Location: Los Gatos, California
Chassis:
065
PostPosted: Sat Dec 01, 2018 9:52 pm
I created a CAD drawing of the current frame. If you still need frame dimension just let me know and I can send you a drawing of the front mounts. I am guessing that someone repaired the frame and the brackets are not welded in the correct place. It is a good idea to use a jig, your local CSR should have one. Bruce @ www.AccelRaceTek.com
User avatar
Still Learning to Type
Still Learning to Type
Posts: 26
Joined: Sun Jul 06, 2014 11:14 pm
Location: Los Gatos, California
Chassis:
065
PostPosted: Mon Dec 03, 2018 1:44 am
I double checked my CAD file with a new frame and what I have is different than the enclosed memo? See below for what I believe are the correct placement of the front and rear brackets. Bruce @ AccelRaceTek
Attachments
118004-B.JPG
Detail B
118004-B.JPG (23.01 KiB) Viewed 257 times
118004-A.jpg
Detail A
118004-A.jpg (25.16 KiB) Viewed 257 times
118004.JPG
UCA & Sway Bar Mounts
118004.JPG (23.94 KiB) Viewed 257 times

Return to Technical and Repair Discussions

Who is online

Users browsing this forum: No registered users and 3 guests